Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Agent NOW Mobile app shows additional consent allow/deny screen after successful authentication - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Agent NOW Mobile app shows additional consent allow/deny screen after successful authentication
KB0821117

Agent NOW Mobile app shows additional consent allow/deny screen after successful authentication


917 Views Last updated : Apr 8, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Mobile apps show a screen that says 'ServiceNow Request would like to connect to your ServiceNow account on instance <instance_name>'

After clicking on 'login' button in the NOW Mobile /Agent apps, we often see an intermediate page that says 'ServiceNow Request/Agent would like to connect to your ServiceNow account on instance <instance_name>'

This screen contains 'Allow' / 'Deny' buttons. This is how the screen looks like:




 

 

Cause

The 'Now Mobile' app uses the 'ServiceNow Request' oauth_entity for authentication and the 'Agent' app uses the 'ServiceNow Agent' oauth_entity.
On any instance, if you add the column named 'Disable Consent Screen' for these two oauth_entity records in list view, it'll have the value 'true'. This means that we will NOT present this page asking the user to 'Allow/Deny' permission.

So when the value for 'Disable Consent Screen' is set as false for any of these two oauth_entity records, the additional consent screen appears.

Resolution

  1. Navigate to oauth_entity.LIST from the application navigator.
  2. Add the 'Disable Consent Screen' field onto the LIST view by using Configure -> List View.
  3. Ensure that this field as true for both 'ServiceNow Agent' and 'ServiceNow Request', if it is false, set it as true and save the changes.

The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.