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Inbound approval emails not approving the records - Support and Troubleshooting
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KB0820864

Inbound approval emails not approving the records


3041 Views Last updated : Jul 24, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

Inbound approve emails are not approving the records instead it's updating the target records. You can check the email log, it is sipping the "update Approval Request" inbound action.


Skipping script 'Update Approval Request', email is a reply, and the record it matches is not in the Inbound Email Action's table


Received id XXXXXX Classified as reply to 'null' via watermark 'YYYYY' in message

Release

New York

Cause

Inbound email WaterMark not matching in  or missing in the sys_watermark table

Resolution

we need to check the approval email watermark exists in the sys_watermark table, if it does not exist check, it unable to match the approval email hence instead of approving it will match update inbound action and updating the record.

Check the sent approval email has an "Omit Water Mark" setting enabled. If it is enabled, the instance will not send watermark in the approval email hence it's causing the issue. 

Uncheck the "Omit Water Mark" from the notification, refer the document to find the Omit an email notification watermark

Related Links

If the watermark is available and still approval failing to check the "Random Watermark Support" plugin is disabled, check below :

Use one of the following workarounds:

(Recommended) Activate the Random Watermark Support plugin. This will cause notifications to produce random watermarks, matching the properties in place and making the instance more secure.

If the Random Watermark Support plugin is not required, set the values of the following system properties to false:

  • glide.email.watermark.generate_random
  • glide.email.watermark.parse_restrictive

This will revert the behavior to use normal non-random watermarks on notifications and for classifying inbound messages. 


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