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Description

We notice business rules are not triggered after upgrading to Orlando. 

Steps to reproduce:

  • provision Orlando instance (no domain separation plugin)
  • create a business rule, on insert, on [incident] table, use script gs.info("#### Hello World");
  • and populate a value other than "global" on the "sys_domain" field
  • notice how it does not run
  • whereas if you create the same business rule in a previous version it worked

Release or Environment

Orlando and newer

Cause

  • due to fixes by PRB1347170 (The getMyGroups() does not work as expected in Domain-separated instance) & PRB1349187 (Domain-separated business rules do not get cached properly)
  • The changes to make sure that only business rules run from global domain when the table is not domain separated for both query() and queryNoDomain()

Resolution

  • The purpose of this article to let developers know how even without domain separation, how adding another value than "global" on the domain field could impact them
  • Also if the domain separation plugin is not active, please do not populate the [sys_domain] field
  • you could change the value of the [sys_domain] field to "global"
  • or to revert back to previous behavior by setting the following property to false
  • glide.sys.domain.skip_non_global_businessrule_if_nodomain ; type true|false ; set: false

Article Information

Last Updated:2020-07-15 09:03:12
Published:2020-07-15