Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Blank page is being displayed when requesting an order guide. - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Blank page is being displayed when requesting an order guide.
KB0820816

Blank page is being displayed when requesting an order guide.


664 Views Last updated : Apr 8, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

In the process of requesting an order guide, when the check out UI action is clicked for the first time it is returning a blank "servicecatalog_checkout_one_v2" page. But it is supposed to return the "servicecatalog_checkout_one_v2" page with shopping cart information. 

Cause

The instance is missing the "Cart Preview Screen (Two Step)" record in Cart Layout.

Resolution

When checkout UI action is used for the first time in the Order Guide, the order page redirects to "servicecatalog_checkout_one_v2" page which is the cart view of the order guide.

In the OOB version, the "servicecatalog_checkout_one_v2" gets the cart layout from "Cart Preview Screen (Two Step)".

In this case, your instance does not have "Cart Preview Screen (Two Step)" cart layout available. So the UI page "servicecatalog_checkout_one_v2" does not have any view or layout or structure to display the cart information.

As there is no information available to display we are observing the blank page.

Importing the  "Cart Preview Screen (Two Step)" record form OOB instance into your instance will fix the issue.


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • Cookie Preferences
  • © 2025 ServiceNow. All rights reserved.
We use cookies on this site to improve your browsing experience, analyze individualized usage and website traffic, tailor content to your preferences, and make your interactions with our website more meaningful. To learn more about the cookies we use and how you can change your preferences, please read our Cookie Policy and visit our Cookie Preference Manager. By clicking “Accept and Proceed,” closing this banner or continuing to browse this site, you consent to the use of cookies.