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Users cannot check out a published article | Troubleshooting - Support and Troubleshooting
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  • Users cannot check out a published article | Troubleshooting
KB0820650

Users cannot check out a published article | Troubleshooting


4946 Views Last updated : Dec 15, 2023 public Copy Permalink
KB Summary by Now Assist

Issue

After a Knowledge Article is published, the author may be unable to contribute to it. This may be because they don't belong to the article's ownership group.

Symptoms

Users with the knowledge role cannot check out a published article and create another version. The Checkout UI action is not available to the knowledge role users.

Steps to Reproduce

  1. Impersonate a user who has the knowledge role and has Can Contribute Access to a Knowledge Base.
  2. Navigate to a knowledge article where the user has Can Contribute access to the knowledge base and would like to check out the article.
  3. Notice that the "CheckOut" UI Action is not visible to the user. The Knowledge Management Advanced plugin is active.

Cause

Identified that the ownership group field on the Knowledge article is made mandatory in the instance. Out of the box, it's not mandatory.

The Ownership Group "ABC" overrides the "Can Contribute" user criteria. So, only the members who are part of the Ownership Group can check out the KB article.

This is the expected behavior out of the box. The last part of the condition is not being satisfied for the user "X" with a knowledge role ---- (new KBVersioning().canCheckout(current))

Checkout UI Action has the below condition:

!(new KBCommon().isStackNameDialog()) && (new KBCommon().isVersioningEnabled()) && (new KBVersioning().canCheckout(current))

Line Number 324 to 328 - Script Include: KBVersioningSNC - https://<instance-name>.service-now.com/nav_to.do?uri=sys_script_include.do?sys_id=e88483e0db122200a042f278f0b8f5d0

//If Ownership Group exist but user is not a member
if(this.isValidFieldWithValue(current,this.OWNERSHIP_GROUP)){
if(!this.hasAnyElevatedAccess(current) && !this.isGroupMemberOrManager(current[this.OWNERSHIP_GROUP]))
return false;
}

The above is returned false [Since the issue is Ownership Group exists in the Knowledge article but a user with knowledge role is not a member of the Ownership Group]

Resolution

  1. Navigate to the script include KBVersioning - https://<instance_name>.service-now.com/nav_to.do?uri=sys_script_include.do?sys_id=1f4b1fe4db122200a042f278f0b8f5a7
  2. Override the function "canCheckout" which is defined in the KBVersioningSNC
    • ie, Remove the above mentioned if conditions.

Related Links

  • Knowledge Management roles product documentation
  • Edit a knowledge article product documentation
  • Ownership groups product documentation

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