Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Unable to change the default sort order for Portfolio's when "Detail Row" System property is used -
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Unable to change the default sort order for Portfolio's when "Detail Row" System property is used
KB0820598

Unable to change the default sort order for Portfolio's when "Detail Row" System property is used


391 Views Last updated : Jan 28, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Unable to change the default sort order for Portfolio’s when Detail Row System property is used

The issue appears to show the Name field not displaying in the list view but rather the number and short description get concatenated. 

 

Cause

The system property "detail_row" was causing the "Name" field which is of type "short description" as a description for the field "Number".

Resolution

There are few ways to solve this issue

1). If you do not want to split number and description in the list and want to keep the "detail row" system property and sort the table by "short description" we can achieve that by following steps:

1). Navigate to the table example pm_project.
2). On the top left corner, click on the "Show/hide filter" button (funnel icon)
3). After clicking the icon, click on the "Add sort" button.
4). You should see "Order results by following fields", Select "short description" and select the order a or z to a
5). Select Run
6). The list is sorted by the program name.

The Short Description field can have a different label name so please select that name while sorting.


2). Deactivating the System property "glide.ui.list_row" which will show the Description and Number in different columns

Doing this would affect all the tables in the global application scope, therefore you can change the scope of the application for the system property.









Related Links

You may find the following documentation useful for future reference:

1). https://docs.servicenow.com/csh?topicname=c_ControlTheListSortSequence.html&version=latest

2). https://docs.servicenow.com/csh?topicname=t_EnableDetailRows.html&version=latest


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.