Issue
Dashboards have widgets display a message "No data to display", even though, the data is present in the table, data collector jobs are collecting data with no issues/errors
Cause
The domain where scores are collected and the domain of 'Run as' user for data collector jobs are different.
Resolution
To collect scores from a particular domain, ensure the Run as user is a member of that domain.
- Navigate to sysauto_pa.LIST
- Look up for the respective data collector and historic jobs related to widget indicators
- Check "Run as" user record details
- Change "Run as" user for the job to the user from same domain where the scores are being collected from.
(or)
- Update "Run as" user record's domain to the domain where the scores are collected from.