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Nusiness Rules are triggered when a record on 'setWorkflow' form is updated - Support and Troubleshooting
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KB0820089

Nusiness Rules are triggered when a record on 'setWorkflow' form is updated


359 Views Last updated : Apr 8, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Business Rules are triggered when e.g. a record on 'incident' form is updated. This triggers a set of Business Rules. If one of the triggered Business Rule invoked setWorkflow(false).

When setWorkflow(false) does not prevent triggering Business Rules?

Release

Supported environment

Cause

No defect. Expected behavior.

Resolution

Business Rules are triggered when e.g. a record on 'incident' form is updated. This triggers a set of Business Rules. If one of the triggered Business Rule invoked setWorkflow(false), this would not abort all Business Rules that would have been triggered by the incident update. It would only prevent any Business Rules to be triggered by the update invoked by this Business Rule, if e.g. it invoked current.update(). The common usage of setWorkflow(false) is in scripts that are executed in background script or fix script.


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