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Live Feed/Chat notifications with change request number - Support and Troubleshooting
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KB0819891

Live Feed/Chat notifications with change request number


1687 Views Last updated : Dec 29, 2022 public Copy Permalink
KB Summary by Now Assist

Issue

Users are getting "chat notifications" through ServiceNow for change requests in the connect chat window.

Cause

This could be of two reasons:

  1. The following Business rule is causing the conversation records to be created.
    • Refresh Impacted Services - https://<your-instance>.service-now.com/nav_to.do?uri=sys_script.do?sys_id=08cf6ffe23203300a5eedc1756bf657f
    • This calls a script includes ChangeUtils which is an extension of another script include "ChangeUtilsSNC".
    • The function "refreshImpactedServices" calls the function getImpactedServicesFromAffectedCIs which in turn calls "_notifyUser".
    • The _notifyUser function creates a new chat conversation with the change request number as the display value(check line number 460).
    • ChangeUtilsSNC - https://<your-instance>.service-now.com/nav_to.do?uri=sys_script_include.do?sys_id=2ddf83eb9fa331002920bde8132e7044. This is sending out the message to the message with the change request number as you see.
  2. A new property for notify messages are introduced in the ROME release on change requests.
    • property Name : com.snc.change_request.refresh_impacted.event

Resolution

For Cause #1:

This business rule is for updating the task_cmdb_ci_service (Impacted Services) table with the configuration item you have selected for the change request. So we would as you not to turn off the OOB business rule. If you do not want the OOB behavior, you can customize the ChangeUtilsSNC script include through the extension "ChangeUtils".

For Cause #2:

A new property named "com.snc.change_request.refresh_impacted.event" for notify messages are introduced in the ROME release for refresh impact services for configuration item (CI) attached on a change request.

NOTE: This property is available only from Rome.

  • This property causes connect chat alerts to show up on change requests for the completion of refresh-impacted services.
  • If this is the case, a process called an event is used to update the affected services. This process is carried out in the background, and after it is finished, a notification will appear in Notify to let you know.
  • When false, your session is used to run this. There is no indication after the refresh impact services have finished because this is not running in the background.
  • By deactivating this property, there is no problem with Refresh impact services having an influence on change requests for a certain configuration item (CI).

Related Links

Refresh impacted services properties


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