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KB Articles are not viewable by non-itil users, or any other non-"xyz" role - Support and Troubleshooting
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  • KB Articles are not viewable by non-itil users, or any other non-"xyz" role
KB0819853

KB Articles are not viewable by non-itil users, or any other non-"xyz" role


1385 Views Last updated : Apr 8, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

You may encounter an issue wherein specific users are seeing the following message:  You do not have sufficient privileges to access this knowledge item

Cause

Usually you'll find that normal lower-level users (ex: non-itil) will have this issue.  There may be several reasons for this, but in this KB we will investigate the ACL + Roles to check.  It's possible that several KB's have been created with a specific role [kb_knowledge.role] specified.  This prevents users from seeing the KB based on the role check in the following OOB ACL:

https://<instance-name>.service-now.com/nav_to.do?uri=sys_security_acl.do?sys_id=7d9dd050c0a801666e1223c8df88a4cc

This can cause confusion if the "Roles" field is no longer present on the [kb_knowledge] Form and/or List views.  This can be the case if other means are typically used for control, like User Criteria.

Resolution

You can confirm/resolve this by adding the 'Roles' field to your Knowledge Form and/or List, or by examining the 'Show XML' data of a [kb_knowledge] record.  Updating the Roles on the KB or ensuring the affected user has the expected roles should resolve this issue.


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