Issue
Connect support chats are being created by "Guest" users.
Release
All latest releases.
Cause
Connect support page is a public page and non-authenticated users can create chat queue records in your instance. To verify the same, access the following link without logging into the instance(In an incognito window).
https://<instance-name>.service-now.com/$chat_support.do?queueID=CHAT_QUEUE_ID
So even if a user was logged out of the instance, they can still create chat records as guest users.
Resolution
To make sure the users are logged in when creating a chat record, you need to make sure $chat_support is not a public page. For that please set active False for the following record.
https://<instance-name>.service-now.com/sys_public_list.do?sysparm_query=active%3Dtrue%5Epage%3D%24chat_support&sysparm_view=
Related Links
The above details hold good for older versions such as Kingston, London.
With the latest release such as Rome & San Diego, the $chat_support.do is no longer visible under the sys_public list.
If any user tries to access the $chat_support.do page without logging in, it will ask for authentication.
With Quebec, Rome & San Diego, you cannot initiate a Connect Support as Guest user anymore.