Notifications

11 views

Description

After loading the knowledge list for example by navigating to Knowledge > Articles > All, the following log warning is seen coming from the KBCommonSNC Script Include:

"This function requires the first argument to be a GlideRecord"

Cause

This only happens when the List v3 is used. This feature is deprecated.

Resolution

Use List v2 by going to System Properties > List v3 and clear the "Enable List v3" checkbox.

Additional Information

Message in the "com.glide.ui.list_v3" plugin:
"Development is no longer actively adding features or fixing issues besides critical outages or security related defects. Activating this plugin could potentially cause unwanted side effects for customers with large and/or complex datasets, or those accustomed to the feature set and performance of List v2. "

Article Information

Last Updated:2020-03-30 05:22:25
Published:2020-03-30