Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Log warning - "This function requires the first argument to be a GlideRecord" - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Log warning - "This function requires the first argument to be a GlideRecord"
KB0819672

Log warning - "This function requires the first argument to be a GlideRecord"


313 Views Last updated : Apr 8, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

After loading the knowledge list for example by navigating to Knowledge > Articles > All, the following log warning is seen coming from the KBCommonSNC Script Include:

"This function requires the first argument to be a GlideRecord"

Cause

This only happens when the List v3 is used. This feature is deprecated.

Resolution

Use List v2 by going to System Properties > List v3 and clear the "Enable List v3" checkbox.

Related Links

Message in the "com.glide.ui.list_v3" plugin:
"Development is no longer actively adding features or fixing issues besides critical outages or security related defects. Activating this plugin could potentially cause unwanted side effects for customers with large and/or complex datasets, or those accustomed to the feature set and performance of List v2. "


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.