Issue
- User is not able to use enter button in the catalog item while filling a multi-line text and cursor is stuck at the end of last alphabet of the word. However, If user keep typing the words all the way to end of the line, it goes to the next line by default.
Cause
- Caching issue, it works on one node and doesn't work on other nodes.
Resolution
- Disable and enable respective catalog client scripts of that catalog item and clear the cache, that will solve the problem.
- Monitor for a day or 2 days, if it happens again, then, there's a PRB1380844 in place.
- The change in the event listener of UI Script "GwtDateTimePickerFix" from 'keypress' to 'keyup', will resolve it.
The world works with ServiceNow.