Issue
When a user is creating a new table by going to System Definition > Tables, clicking on the "Auto-number" checkbox, the fields "Prefex", "Number" and "Number of digits" do not appear on the form.
Release
All
Cause
This is due to the OOB UI Policy Controls when the autonumber fields and checkbox should show being customised.
Resolution
Revert the UI policy Controls when the autonumber fields and checkbox should show back to OOB version through the "Versions" related list.
If the "Versions" related list is not visible, you will need to configure this via the right-click context menu and selecting Configure > Related Lists.
If this does not resolve the issue, then look to see if other scripts are hiding these fields.