Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Changing DNS MX records with a large TTL (Time to Live) to a new email server could cause some relays to route to the old email server - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Changing DNS MX records with a large TTL (Time to Live) to a new email server could cause some relays to route to the old email server
KB0819182

Changing DNS MX records with a large TTL (Time to Live) to a new email server could cause some relays to route to the old email server


1531 Views Last updated : Apr 8, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

After Customer has switched their Corporate email server from, say, Gmail to Exchange by updating their DNS MX Record, the Companies' emails coming from ServiceNow instance, are still going to the Gmail accounts instead of Exchange.

This issue may only happen with emails coming from ServiceNow instance. Other emails coming from other sources may be correctly going to Outlook mailboxes via Exchange as expected.

Cause

 TTL (time to live) of the DNS record which defines the MX Record is too high so the change is not propagated in a timely manner.

Resolution

The issue can be prevented by taking action before updating their DNS MX Record:
  1. The TTL for the DNS record should be set to a very low value, for example 5 minutes.
  2. Confirm that email routing is occurring as expected to the new email server.
  3. Finally revert the TTL back to initial value.

If the MX record has already been updated where the DNS TTL was not set to a low value, ServiceNow cannot assist – However, after 2 days the propagation will be completed without any intervention from ServiceNow



 


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.