Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Issue with the Flow designer not getting/delay in triggering - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Issue with the Flow designer not getting/delay in triggering
KB0819167

Issue with the Flow designer not getting/delay in triggering


2728 Views Last updated : Apr 8, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

The flow engine is not processing the Updates faster and which results in the delay of updates to the Major Incidents.. In the processing duration for the events in event queue for few incident records. It took so long for processing the updates from flow designer. It’s not expected behavior usually the updates would happen no longer than 60secs.

When it is happening:

It is happening occasionally where the event processor is busy and once the event queue is cleared , the updates are happening to the Incidents.

Requirement:

To run the Flow synchronously for the flow that you have configured on MIM incidents.

Release

ALL

Cause

Configuration of "When to run the flow"

Resolution

The Flow engine can be run synchronously by changing the "When to run the flow" to "Run flow in foreground".

Option Description in the product document :

Run flow in background (default) Flow that runs asynchronously in the background. Use this option for flows that do not require immediate updates and to allow other system processes to run at the same time.

Run flow in foreground Flow that runs synchronously in the current session. Use this option to provide immediate updates to an end user. For example, if a flow opens a task after the previous task closes, use this option to open the next task immediately after a user closes one.
Note: Running a flow in foreground blocks the current session thread and prevents it from running anything else until the flow finishes. To avoid making your system unresponsive while running a flow, do not use this trigger option for flows that take a long time to complete.


Related Links

Refer the below Flow Designer Document regarding the triggering options.

CLICK HERE


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.