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SLA are not running with caller timezone - Support and Troubleshooting
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  • SLA are not running with caller timezone
KB0819098

SLA are not running with caller timezone


1055 Views Last updated : Apr 8, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

SLA definition is have Timezone source is "the caller's time zone" but still task sla is having system default timezone.

Release

All Release

Cause

Timezone calculate from TaskSLA script include  

gr.timezone = SLATimezone.source(tzSource, gr, taskGR);

TaskSLA , SLATimezone if both are OOB then please check when the Task SLA is created 

Generally Task SLA creates first then request will create 

if request requested for and task sla creation is having 2 -3 sec duration then timezone of SLA will have default timezone rather than caller timezone as at that time requested for is not at set on request 

Resolution

To avoid the issue if RITM is having workflow to create catalog task then add 10 sec timer before catalog task so request will create first then Task SLA will have caller timezone.


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