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Cannot connect to Servicenow instance from Tableau - Support and Troubleshooting
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  • Cannot connect to Servicenow instance from Tableau
KB0819095

Cannot connect to Servicenow instance from Tableau


2951 Views Last updated : Aug 23, 2022 public Copy Permalink
KB Summary by Now Assist

Issue

It is possible to integrate the Tableau client application to run queries for reporting purposes.

When trying to connect from Tableau to your instance, the following error is shown "You are not authorized to access this resource. Check with your ServiceNow administrator to verify that the access control lists have the correct permissions set."

Release

All

Cause

Out of the box, ACLs created by default for a new user in Servicenow are not sufficient to allow Tableau to connect.

 

 

Resolution

As per the Tableau docs, the following permissions are required

How to connect Tableau to ServiceNow IT Service Management (ITSM) data and set up the data source

For ServiceNow administrators
ServiceNow uses access control lists (ACLs) to specify who has access to which data. Often the default permissions that are set for ServiceNow fulfillers are adequate for Tableau users to access the content they need to analyze ServiceNow ITSM data.

Tableau users need to access metadata about tables in ServiceNow, which is available in the following tables:

sys_dictionary table (metadata about columns)
sys_db_object table (metadata about tables)
sys_glide_object table (metadata about field types)
If a Tableau user can't access ServiceNow ITSM data, make sure that the ACLs provide the user table level and field level read access to the tables above, and that there are no scripts that are locking down access.

To grant access to the metadata tables, as a best practice, you might consider creating a role with the ACLs needed to access the metadata tables, and then assign the role to a Tableau User group. Then, you can assign Tableau users to the group so that users can access the data needed for analysis in Tableau. Test read access to the tables by impersonating the user, you can also try adding the roles 'itil', 'snc_read_only', and 'delegated_developer' instead.

For information on the creation of an ACL, please see our Documentation on ServiceNow Access control list rules.


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