Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Surveys are not getting generated - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Surveys are not getting generated
KB0818960

Surveys are not getting generated


2456 Views Last updated : Apr 8, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Survey emails are not triggered and surveys are not generated.
Error on the form when survey is assigned "Instance could not be created"

Cause

Possible reasons and fixes to check :
When the category is missing for the assessable record, it leads to the error: "Instance could not be created"
On the table : asmt_m2m_category_assessment, category was missing for the assessable record : On creating that , the issue is resolved.
Things to check in the case of similar error :
-asmt_assessable_record
-asmt_m2m_category_assessment
-asmt_metric_type

Also check if OOB Script include:AssessmentUtils is as per OOB.

Resolution

When we create a new record in asmt_m2m_category_assessment table issue is resolved


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.