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Alert list in the Event Management dashboard do not reflect the current state of alerts belonging to an Alert Group service - Support and Troubleshooting
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KB0818247

Alert list in the Event Management dashboard do not reflect the current state of alerts belonging to an Alert Group service


690 Views Last updated : Apr 8, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

In the event management dashboard, the alert list that appears below the service tiles is not updated or in sync with the actual alerts that belong to the Alert Group services

Cause

There is an issue with the Event Management dashboard. The severity of the alert group service returns correctly, however, the problem is that the alert list doesn't refresh and returns old data.

This happens only for alert groups, only for cases when the severity of the group hadn't changed and only if there wasn't any change on the alert list (due to other services).

 

Resolution

The workaround for the issue is to change the alert groups status from operational to non-operational and back. If needed, you can create a scheduled job that does it every minute to all the alert groups.

This happens only with the legacy event management dashboard, which will be deprecated starting Orlando release. This does not happen with the new operator workspace, which is available in Orlando for all customers. 

You can run this script in the scheduled job for flipping the operational status:

var gr = new GlideRecord("cmdb_ci_alert_group");
gr.addQuery("operational_status", "1");
gr.query();

while (gr.next()) {
gr.setValue("operational_status", "2");
gr.update();
gr.setValue("operational_status", "1");
gr.update();
}

 


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