Notifications

3 views

Description

"Author" Filter is missing in KB after NewYork upgrade for all the End Users.

   Steps to reproduce:

  • Impersonate any end user with out any admin/itil role.
  • Try to access the $knowledge home page
  • Search for any keyword.
  • In the Search Filter section, we can see the "Author" filter is missing

 

Release or Environment

Newyork

Cause

The author filter is being hidden because for the /api/now/v1/knowledge/search/facets query the "Author" array is returned empty. This can be seen in the browser console.

Resolution

Check for custom Query BR's on the sys_user table and in this scenario only the Field value has empty data and which would cause the Field to be hidden.

Article Information

Last Updated:2020-03-17 23:15:10
Published:2020-03-18