Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
$change_request_calendar_view / conflict calendar page blank for non-admin users - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • $change_request_calendar_view / conflict calendar page blank for non-admin users
KB0818138

$change_request_calendar_view / conflict calendar page blank for non-admin users


711 Views Last updated : Apr 8, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

When clicking the "Conflict Calendar" ui action and viewing a change in the "change_request_calendar_view" view, no data is displayed for anyone except admins.

Release

All releases.

Cause

The reason for this behavior is the ACL "Table API" was activated which is inactive OOB.

Resolution

1. If you wish to keep it active, please grant the role "snc_platform_rest_api_access" to the required user(s) as defined in the ACL.
2. This will the pass 'GET' rest API and will load the frame in the $change_request_calendar_view page.


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.