Issue
Business Service (cmdb_ci_service) records are not visible in the instance
To reproduce: Try sorting the cmdb_ci_service table on "Updates" by right-clicking the mouse over the column header and selecting sort (a-z)
Release
New York (Occurs on UI16 form layout)
Cause
It could appear that there is a UI policy which hides the display of records when you right-click on column header "Updates" (in my case) and select sort (a-z)
This appears to be a cosmetic issue if the following all checks out:
- check the security by applying debug and examining the rules
- changing the view does not resolve the issue
- logging in as any user and you are able to reproduce the issue
In this case the "updates" column was hiding the records which is likely due to UI policies
Resolution
To resolve: Sort (a-z) cmdb_ci_service on any other column
For further assistance on UI policies log a support call with ServiceNow support
Related Links
cmdb_ci_service > sort on Updated column is hiding records
Steps to reproduce:
- Log in to instance
2. Impersonate user
3. Open business service table (cmdb_ci_service.list) in the filter navigator (nav_to.do)
4. Right-click on "Update" and select sort (a-z) - notice the records are not visible
5. Right-click on "Name" and select sort (a-z) - notice the records are visible