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When a RITM has multiple level of approvals, there is no history of previous approvals - Support and Troubleshooting
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  • When a RITM has multiple level of approvals, there is no history of previous approvals
KB0817579

When a RITM has multiple level of approvals, there is no history of previous approvals


874 Views Last updated : Sep 21, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

When a RITM has multiple approval levels, there is no history of the previous approvals. ie. For example, after a manager (X) approves the RITM, approval request is sent to manager's manager (Y). When this approval record is generated, the previously generated approval record for manager (X) no longer exists.

Cause

This is an expected behavior when same "Approval - User" activity is called multiple times to generate the approval records, in which case, the previously generated approval record no longer exists.

Resolution

Avoid calling the same "Approval - User" activity multiple times, instead call this activity ONLY ONCE providing list of all approvers at once OR use different "Approval - User" activities to generate those approval records, in both these cases the previously generated approval records will exist.




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