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Inconsistent Data in User, Group, and Contacts related tables after Instance Clone - Support and Troubleshooting
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KB0817569

Inconsistent Data in User, Group, and Contacts related tables after Instance Clone


19950 Views Last updated : Jul 8, 2025 public Copy Permalink English (Original)
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KB Summary by Now Assist

Issue

Unexpected results in the User [sys_user], Group [sys_user_group], and Contacts [customer_contact] related tables may have occurred after an instance clone was performed.

Release

  • New York
  • Orlando
  • Paris
  • Quebec
  • Rome

Cause

After 7th Feb 2020 and Before 1st May 2020 the Preserve users and related tables functionality was enabled. When submitting an Instance Clone request, by default Preserve users and related tables is checked. As a result, this will Exclude and Preserve User related tables data in the target instance.

The following tables are affected:

  • sys_user
  • sys_user_group
  • sys_user_grmember
  • sys_user_role
  • sys_user_has_role
  • customer_contact

Afterward, we - ServiceNow has investigated that the clone functionality Preserve users and related tables does not work as expected and is now disabled for all clones. See PRB1351704.

After 1st May 2020, ServiceNow has disabled the Preserve users and related tables functionality. Even if this Preserve users and related tables is checked or not in the Instance Clone request, this will not Exclude and Preserve User related data in the target instance.

Resolution

After 7th Feb 2020 and Before 1st May 2020 the Preserve users and related tables functionality was enabled. When submitting an Instance Clone request, by default Preserve users and related tables is checked. As a result, this will Exclude and Preserve User related tables data in the target instance.

The following tables are affected:

  • sys_user
  • sys_user_group
  • sys_user_grmember
  • sys_user_role
  • sys_user_has_role
  • customer_contact

Afterward, we - ServiceNow has investigated that the clone functionality Preserve users and related tables does not work as expected and is now disabled for all clones. See PRB1351704.

After 1st May 2020, ServiceNow has disabled the Preserve users and related tables functionality. Even if this Preserve users and related tables is checked or not in the Instance Clone request, this will not Exclude and Preserve User related data in the target instance.

Resolution

Note: All preserve and exclude settings are taken from the SOURCE instance used by the clone. Ensure these settings are set on the SOURCE, not the target instance.

Create the following Excludes:

  • sys_user
  • sys_user_role
  • sys_user_has_role
  • sys_user_group
  • sys_user_grmember
  • sys_group_has_role
  • sys_user_role_contains
  • customer_contact (Note: Only if you have the Customer Service Management plugin installed)

This will not bring over any users from the source instance or any of the references to groups and roles, but the sys_user table still needs to be preserved. Note: Roles, groups, and also the links from users to roles and groups will need to be preserved.

Create these Preservers: (Add any conditions depending on your requirements)

  • sys_user
  • sys_user_role
  • sys_user_group
  • sys_user_grmember
  • sys_user_has_role
  • sys_group_has_role
  • sys_user_role_contains
  • customer_contact (Note: Only if you have the Customer Service Management plugin installed)

This will preserve all the users, roles, and groups in the target instance, but it will also preserve the permissions of those users to those groups and roles.

This is documented in the following article for Create a data preserver.

Related Links

Request a Clone


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