Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
In reporting, the Variables[+] can show up 2 times in the slushbucket for sc_task/sc_req_item - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • In reporting, the Variables[+] can show up 2 times in the slushbucket for sc_task/sc_req_item
KB0817410

In reporting, the Variables[+] can show up 2 times in the slushbucket for sc_task/sc_req_item


482 Views Last updated : Apr 8, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Sometimes you may find that for tables sc_task or sc_req_item, the selection of criteria for Variables [+] shows up 2 times in the availability slush bucket.

This is visible in the classic report UI, but not in the new report UI. Additionally, if we filter for variables in the list view for the above tables, we can see that variables are appearing twice in the filter. 


Cause

The dictionary entry for the variable field in task table is marked as active=true causes this behavior to get displayed.


Steps to reproduce :

1. Log in to the instance.

2. Proceed to system dictionary(sys_dictionary.LIST in the left pane navigation bar).

3. Search with the table as task and column name as variable.

4. Mark variable as Active = true.

5. Open sc_tak in list view.

6. Filter for variables. You can see two entries for the variables.

7. Open report builder classic UI, and select table as sc_task. 

8. Check for variable+ field in the availability slush bucket. It should be available twice.


Resolution

Marking the dictionary entry for the variable in the task field as active=false will resolve this issue(current OOTB setting).


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.