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Send To Event Creator is not Sending the Notification to the User who has triggered the Event - Support and Troubleshooting
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KB0813747

Send To Event Creator is not Sending the Notification to the User who has triggered the Event


6458 Views Last updated : Aug 23, 2023 public Copy Permalink
KB Summary by Now Assist

Issue

When a notification is supposed to be sent to approver of request and in the notification configuration, if send to event creator is set to True, then the notification will be sent to only the approver of the request, it will not be sent to event creator.

Cause

Consider a  notification is sent when a RITM request is sent for approval. The notification is sent to the approver group. The Approver group has 4 members to whom the notification is to be sent. (Suppose User A,B,C,D)

If One of the 4 users (Suppose A) moves the RITM to the Approval Stage, 

Scenario 1. 
Send to Event Creator is set to True - 

All the 4 members will be sent the notification email.

User A will be added as Event Creator

Scenario 2 - Sent to Event Creator is Set to False

Only 3 members will receive the notification and not the User who has triggered the notification. (Users B,C,D will receive notification and A will be excluded as A is the event creator).


Resolution

Business Logic behind this functionality is Users may not need to be notified for the actions they have taken or the actions triggered by some of the action performed by user.

In certain scenarios where users are to be notified even for actions performed by them, we can enable the setting of Send to Event Creator on notification record.


In order to enable 'send to event creator' you might have to switch to 'advanced view' and go to the 'Who will receive' tab.

Check or uncheck this option as needed.


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