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Description

Dot walk field values do not appear within the condition builder/filter dropdown field

Release or Environment

This happens within all instance versions as it is expected OOB behaviour.

Cause

This is expected OOB behaviour.

Resolution

First, let's make sure that the field in question is a dot-walk field.

  1. Go to the list view of the desired table. - Application Navigator --> <name of desired table list>.
  2. Click on the 'hamburger' icon.
  3. Configure --> Form Layout. - Make sure that you are on the correct section where the field is.
  4. Evaluate if the field is a dot-walk field or not. - You will be able to tell if the field is a dot-walk field as it will have a dot (.) within the middle of its name, i.e. Assigned to.User ID

Now that we have evaluated that the field in question is indeed a dot-walk field, you will notice that the field value will not appear in the condition builder. We can follow these steps to be able to select the value of the dot-walk field within the condition builder:

  1. Go the list view of the desired table.
  2. Within the '-- choose field --' condition buiilder dropdown field, select the 'Show Related Fields'.
  3. Open the condition builder dropdown field with the 'Show Related Fields' value. Here, search for the desired dot-walk field that you wish for the values to be selectable, i.e. Assigned to.User ID
  4. After selection the 'Assigned to.User ID' field, the values for this dot-walk field will appear and will be selectable in the condition builder.

 

Please do know that documentation 'Dot-walking examples', which can be found here:

https://docs.servicenow.com/bundle/newyork-platform-user-interface/page/use/navigation/reference/dot-walking-examples.html

Has a great step-by-step guide on how to solve this issue in the 'Condition builders' section.

Article Information

Last Updated:2020-02-11 06:38:34
Published:2020-02-11