Issue
When adding a new schedule entry to a CAB definition the schedule entry will show a different timezone than the timezone on the CAB definition. They should be the same.
Cause
The timezone on the CAB definition is not properly configured as a valid choice. This mostly happens when the timezone set as the system timezone is not set as a valid choice for users or if the CAB definition is imported from another instance where different timezones are configured.
Resolution
As an admin go to any entry in the sys_user table and right click on timezone and select configure choices. Then add the timezone that is on the CAB definition to the list of Selected choices.