Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Slow queries from "Error Manager - Update Counters" - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Slow queries from "Error Manager - Update Counters"
KB0813070

Slow queries from "Error Manager - Update Counters"


761 Views Last updated : Apr 8, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Slow queries from job "Error Manager - Update Counters".

Release

All currently supported environments.

Cause

The "Error Manager - Update Counters" updates the values in "Discovery > Home" and "Discovery > Home > Schedules" (errors per schedule). It runs queries on automation_error_msg and updates automation_error_code_stats. The queries can take longer as the automation_error_msg table grows.

Resolution

  1. Lower the frequency of the "Error Manager - Update Counters" job to once every hour or even once every day (this will depend on how often these pages are used).

The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.