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Source selector is not visible under the related search results - Support and Troubleshooting
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  • Source selector is not visible under the related search results
KB0812534

Source selector is not visible under the related search results


1295 Views Last updated : Jul 24, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

Source Selector box does not appear to the right of the Related Search field on the incident form.

STEPS TO REPRODUCE:

  1. Contextual Search -> Table Configurations
  2. Update the configuration for Incident (UI type =platform, Search context = Incident Deflection) so 'Enable source selector' is checked.
  3. Create a new incident record and type some text into the Short description field
  4. Verify that the Source Selector box doesn't appear to the right of the Related Search field


Cause

From the Search Context(Incident Deflection): /cxs_context_config.do?sys_id=091fa3d3c37221003d2ae219cdba8f0e

associated to the Table Configuration: /cxs_table_config.do?sys_id=b3ca5632c32121005655107698ba8fba

Under the Searcher field, only "Knowledge Only" is selected and if this is the value, then no source selector will be available as this is just a one field which doesn't require to be selected.


Resolution

1. Change above mentioned value to "Knowledge, pinned knowledge and catalog", then you will be able to see the source selector box next to the search field.

2. Also, with Search on tab unselected, only you will be able to see the default configurations and the additional resources will be available for example like: Open Incidents, Open Changes, etc, then this must be selected. This is documented in below link:

https://docs.servicenow.com/csh?topicname=t_DefineSearchContext.html&version=latest


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