Issue
If customers have set up and embed Virtual Agent to an external website through an iframe, some topics are not available in Virtual Agent after clicking on "Show Me Everything"
Release
All
Cause
There is no "public' role set for the Virtual Agent Topic.
Resolution
From the Create a Virtual Agent topic product documentation it specifies "If a topic is public (available to users, including guest users, who are not authenticated in ServiceNow), select only the Public role."
To resolve the issue, add the "public" role to the topic you wish to be displayed when accessing Virtual Agent embedded in an external website.