Issue
Audit delete schema not updated to store delete recovery data: sys_id
Cause
delete_recovery field is missing on the sys_audit_delete table
Resolution
The field delete_recovery was added via the plugin Delete Recovery: Partial Undelete Support which was introduced in London.
Please find the same document about the same below.
https://docs.servicenow.com/csh?topicname=list-of-plugins.html&version=latest
Activating the plugin should bring in the field and should resolve the issue. Please find the URL for the same below.
https://<instance>.service-now.com/nav_to.do?uri=%2Fv_plugin.do%3Fsys_id%3Ddelete_recovery.partial_undelete