Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Read-only Knowledge Articles from contextual search(glide.knowman.contextual_search.show_read_only_article) : Property missing post upgrade - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Read-only Knowledge Articles from contextual search(glide.knowman.contextual_search.show_read_only_article) : Property missing post upgrade
KB0794149

Read-only Knowledge Articles from contextual search(glide.knowman.contextual_search.show_read_only_article) : Property missing post upgrade


618 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Go to any upgrade instance to NewYork and notice the property (glide.knowman.contextual_search.show_read_only_article) is not present in the sys_properties table.

Release

All instance upgraded to New York

Cause

This property will be present only on net new NewYork instances. For the instances upgraded to New York, the property has to be created manually.

Resolution


Note: The usage of the property is to - Displays a read-only article view page when knowledge articles are viewed from contextual search.

In order to create the property please follow the below steps:
Step 0: Download the property to the Knowledge article. (See bottom of the KB article).
Step 1: Login to instance where you want to add the property. (Should be an admin in order to make changes)
Step 2: On the navigation filter type - sys_properties.list
Step 3: Right click next to the value field (attached a screenshot to the KB article)
step 4: Select import XML
Step 5: Select the downloaded file as stated in Step 0
Step 6: click on Upload

now search with the name in sys_properties table and property is now added into the instance.

Related Links

https://docs.servicenow.com/csh?topicname=r_KnowledgeProperties.html&version=latest


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

Attachments

Attachments

  • Screen Shot 2020-01-22 at 7.37.42 AM.png
  • sys_properties_9f2a93f1535323008bd7ddeeff7b127e.xml

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.