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LDAP Users cannot login and receive error "User name or password invalid" - Support and Troubleshooting
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  • LDAP Users cannot login and receive error "User name or password invalid"
KB0794144

LDAP Users cannot login and receive error "User name or password invalid"


5153 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

LDAP Users cannot login via LDAP even after passing correct Username and Password and receive error User name or password invalid.

 

Release

Applicable to all release

 

Cause

Related LDAP Server is not using MID Server but when checking system logs corresponding to login attempt it shows below warning

*** WARNING *** LDAP Auth through MID server is not supported!

This warning appears because authentication was performed against a different LDAP Server which is configured with MID Server. And, this happens when LDAP Server field in sys_user record is empty.

When this field value is empty, platform does not know which LDAP Server to query and it picks an LDAP Server randomly. And, if that randomly picked LDAP Server is not the one where the logged-in user belongs to and is configured with MID Server, authentication fails with above warning.

 

Resolution

Update the LDAP Server field in sys_user record(s) with related value and user(s) are able to login.

 

Note: It is a best practice to always populate the LDAP Server field in a sys_user record. Leaving this field empty is fine when you're using only LDAP Server. But, when there are more than one LDAP Servers configured, you may face this issue.


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