Issue
All incident SLA notifications(50%, 75% & 100%) are sent at the breach time.
Cause
In the SLA definition, the breach time is set as as 'Due date' and in the Start conditions: Retro active start > 'set start to' is set as 'due date'.
That's why the SLA starts when it matches the due date.
Resolution
Change Retro active start --> 'set start to' = created
OR
Uncheck the "Retro active start" field.