Issue
Users redirected to the deactivated Identity Provider URL and able to login successfully with the deactivated Identity Provider instead of the newly configured Identity Provider URL.
Example : Multi Provider SSO configuration keeps sending users to ADFS Identity Provider record, instead of the newly created Microsoft Azure Identity Provider record.
Release
All
Cause
Script Include SAML2_update1 was customised on customer instance and was causing the issue.
Resolution
Reverting the SAML2_Update1 script include to out of the box fixed the issue.