Issue
Classic Mobile: Details screen does not load, it gets stuck in the loading screen
Release
Classic Mobile application
Cause
This is caused by having an unsupported feature or field type in the view.
First verify that the table has a Mobile view, if it does not, create a new Mobile view on that table and add the desired fields. If a mobile view already exists, please verify that the fields on the form are supported on Mobile, to determine please use the below article.
https://support.servicenow.com/kb_view.do?sysparm_article=KB0551212
Resolution
Create a Mobile view if one does not exists or remove the unsupported fields from the view.
Related Links
https://support.servicenow.com/kb_view.do?sysparm_article=KB0551212
https://docs.servicenow.com/csh?topicname=c_NavigationAndTheUserInterface.html&version=latest