Issue
If multiple guided tours exist on a form, the order in which they appear does not appear to be alphabetical. For example, if we have the following Guided Tours:
1 - Xxxx
2 - Yyyy
3 - Zzzz
These tours may show up in a different order, instead of 1, 2, 3.
Release
All releases
Cause
If auto-launch is not used, then guided tours are displayed in the order of the 'sys_id' by default. This is expected behavior, as the platform doesn't provide any other way to order them.
Resolution
Utilize auto-launch to launch a specific tour, or open an Idea via the Idea Portal on the ServiceNow Community website.