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Unable to create a recipient list - Support and Troubleshooting
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  • Unable to create a recipient list
KB0793084

Unable to create a recipient list


491 Views Last updated : Jul 24, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

A specific User is trying to create a recipient list to be used with a survey however the form does not retain the information and will not allow to submit a condition.

When user 'James White ADMIN' is trying to create a recipient list to be used with a survey the form does not retain the information and is behaving oddly.

for e.g.

a. when this user is trying to create a new record, the form does not seem to fully load with all the expected fields (Table, User field, Condition)

b. on other recipient lists that have been created successfully by other users, this User is not able to see the value in the 'User' field on the 'Recipients List' form.


Steps to Reproduce: 

Impersonate 'James White ADMIN' account and click 
Survey --> Administration --> Recipient list
Then create a new instance.

Enter the following values:
Type: Internal Users
Table: core_company
User field: CIO
Condition: cio.active = true

 

In browser console, we can see error that shows:

Uncaught Error: [$injector:modulerr]

 

Cause

We determined this User is using the old UI15 which appears to be causing the browser console error.

We could confirm the behavior does not occur for other Users when logged into the same instance using UI16.
Neither do these accounts experience the angular browser console error.

Resolution


My recommendation is that you move to UI16.
Change your UI to UI16, from the old UI15.


You can do this by navigating to the Application Settings (cog wheel) and click 'switch to UI16.

For your reference:
https://docs.servicenow.com/csh?topicname=t_SwitchBtwnUi16AndUi15.html&version=latest


Above fixed the issue.


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