Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Workflow is not getting triggered for a Requested Item record - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Workflow is not getting triggered for a Requested Item record
KB0792489

Workflow is not getting triggered for a Requested Item record


771 Views Last updated : Sep 21, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Workflow for a RITM record is not getting triggered

Release

NewYork

Cause

There was a custom Before Query business rule on the 'Request' (sc_request) table 

Resolution

There was a custom Before Query business rule on the 'Request' (sc_request) table which in turn called another custom script include that again tried to lookup the request record.

So the script include would again trigger the before query business rule which would lead to a recursive loop and transaction would eventually timeout.

Therefore the Request record was never inserted and therefore the RITM workflow was not triggered.


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.