Issue
Workflow for a RITM record is not getting triggered
Release
NewYork
Cause
There was a custom Before Query business rule on the 'Request' (sc_request) table
Resolution
There was a custom Before Query business rule on the 'Request' (sc_request) table which in turn called another custom script include that again tried to lookup the request record.
So the script include would again trigger the before query business rule which would lead to a recursive loop and transaction would eventually timeout.
Therefore the Request record was never inserted and therefore the RITM workflow was not triggered.