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Email undeliverable when Email Account Configured with Exchange's SMTP Server - Support and Troubleshooting
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KB0792458

Email undeliverable when Email Account Configured with Exchange's SMTP Server


3288 Views Last updated : Aug 24, 2022 public Copy Permalink
KB Summary by Now Assist

Issue

Email undeliverable when Email Account Configured with Exchange's SMTP Server


Symptoms

-Using server smtp.office365.com

-port 587 is configured 

-Error in node logs show: com.sun.mail.smtp.SMTPSendFailedException: 530 5.7.57 SMTP; Client was not authenticated to send anonymous mail during MAIL FROM

Cause

When connecting to the Exchange endpoint smtp.office365.com, it is required to authenticate with a user that has an Exchange Online mailbox and that the SMTP sender email account is configured to use TLS. 

Resolution

Enabling TLS for your SMTP email account

  1. Navigate to email account 
  2. Select Connection Security with TLS 

Related Links

Please see Non-delivery reports in Exchange Online (https://docs.microsoft.com/en-us/exchange/mail-flow-best-practices/non-delivery-reports-in-exchange-online/non-delivery-reports-in-exchange-online). 


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