Issue
Priority data lookup rules are not working on the problem table. When the Impact and Urgency are changed, Priority is not updated. It works fine on the incident table but not on the problem table.
Cause
For the Problem table, we look at the table dl_problem_priority for the data lookup rules. The issue is caused if there is no data in this table.
Resolution
You can import the records in this table from out-of-the-box instance or can create your rules. Please find the attached XML which contains the out-of-the-box data.