Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
How and when are custom URLs used in Email links / templates ? Is it possible to use both the original Servienow URL and the custom URL ? - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • How and when are custom URLs used in Email links / templates ? Is it possible to use both the original Servienow URL and the custom URL ?
KB0792321

How and when are custom URLs used in Email links / templates ? Is it possible to use both the original Servienow URL and the custom URL ?


6372 Views Last updated : Apr 8, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Is it possible to have a user base reference the Servicenow URL and another user base reference a custom URL ?

Release

All

Cause

It is **not** recommended for end users to use both the new custom URL and the original Servicenow instance URL because only one instance URL can be set at a time for URL link generation.

Resolution

Custom URL configuration overview:

  • 1. Purchase a custom URL from a domain provider.
            A certificate from LetsEncrypt is automatically used for custom URL configuration.
  • 2. In ServiceNow, activate custom URL plugin
  • 3. Add a Custom URL record by filling in Domain name(your custom URL) and choose a service portal url to redirect users to when they access instance using custom url.
  • 4. Submit. ServiceNow takes upto 6 hours to complete custom URL creation.
  • 5. The instance administrators receive an email when custom URL is "Active".
  • 6. Once the URL is "Active", set it as instance URL by clicking the "Set instance URL" button.

This will result in the custom url being used for all outbound urls.
glide.servlet.uri updated for ${URI} and ${URI_REF}.
glide.email.override.url

Please note that only one instance URL can be set at a time for URL link generation.


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.