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Custom field does not display choice values on the Major Incident workbench resolve UI Page - Support and Troubleshooting
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KB0791887

Custom field does not display choice values on the Major Incident workbench resolve UI Page


822 Views Last updated : Apr 8, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

A custom field is used on incidents where a data policy is makes the field mandatory when resolving the incident. From the major incident workbench, when clicking the resolve button an error would appears. After configuring the custom field to the resolve UI page, the choices for the field will not display.

Release

All releases.

Cause

Using the Resolution code as an example from the resolve UI page (mim_workbench_resolve) we see that the choice values are pulled from another script. The 'Incident' Scripted REST Resource is used to call the getCloseCodes function from the MIMWorkbenchUtil script include. This function queries the close code choices to populate in the resolve UI page.

The issue here is that the Incident Scripted REST Resource has a read-only protection policy and cannot be customized.

Resolution

Additional customizations should be completed on the UI Page to query the choice values that are required.


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