Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
A specific event fires but does not trigger the concerned notification - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • A specific event fires but does not trigger the concerned notification
KB0791868

A specific event fires but does not trigger the concerned notification


4610 Views Last updated : Sep 16, 2023 public Copy Permalink
KB Summary by Now Assist

Issue

 Notification defined to be triggered when event X is fired but firing that event X unable to trigger the same notification.

Cause

  • Event Name is inconsistent between the event registry and the generated event (in event logs).
  • There is an extra space at the end of event name - "X " in event registry.

Note:

That said if the event name in event registry do not match with name in event logs or vice-versa would cause the concerned notification to not trigger.

Resolution

Make sure the event name defined in event registry is same as that in the event generation(Name that comes up in the event logs).

Related Links

In this issue scenario we have taken into account that preview notification already working fine, cmn_notif_device, cmn_notif_message tables have got proper records for "who will receive" users


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.