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Change Schedule calendar view does not show blackout window where the source field is [change_request] - Support and Troubleshooting
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  • Change Schedule calendar view does not show blackout window where the source field is [change_request]
KB0791815

Change Schedule calendar view does not show blackout window where the source field is [change_request]


3013 Views Last updated : Apr 8, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Change Schedule calendar view does not show blackout window where the source field is [change_request]

 

STEPS TO REPRODUCE:

  1. Create a blackout schedule where source field is set to [change_request]
  2. add some conditions, example: active = true, short description = SNC
  3. create a change schedule definition, with the same condition as above
  4. create a normal change that would match the conditions above, with NO affected CI
  5. back in your change schedule definition, click on show calendar

    Expected behavior: the blackout schedule should appear in this calendar view (see screenshot)
Unexpected behavior: the blackout schedule that we created where the source is change_request does not appear

 

blackout schedule is shown

Release

This was tested in New York Release

Cause

As with the calendar view for conflict detection, a change request must have the following fields populated:

  • Configuration item, except in advanced mode. In advanced mode, the Affected CIs field is required instead.
  • Planned start date of the change request.
  • Planned end date of the change request.

this is how the functionality for conflicts works. We don't want to show one view of the change on Change Schedules versus one on the Change Request. If the correct fields aren't populated, it's not going to show.

 

Resolution

Once we populated the affected CI field, the blackout schedule appears in the calendar view for the change schedule we created.

Related Links

Detect conflicts manually and review conflict details


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