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Knowledge article search results blank in kb_view page - Support and Troubleshooting
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KB0791715

Knowledge article search results blank in kb_view page


805 Views Last updated : Apr 8, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

No results is displayed when searching for some knowledge articles from the short description of a call or incident.

Release

New York Patch 4 Hot Fix 1

Cause

Below are the errors from the node logs while searching for knowledge articles.

2019-12-30 04:46:16 (272) Default-thread-8 23FC7B991B0A845033B4FDDACD4BCB25 txid=2c0eff1d1b0a WARNING *** WARNING *** JoinQuery invalid field name: sum_of_70023844
2019-12-30 04:46:16 (278) Default-thread-8 23FC7B991B0A845033B4FDDACD4BCB25 txid=2c0eff1d1b0a SEVERE *** ERROR *** ftp://gsft_database/kb_search_results_v3:12:14: Method "toString" called on incompatible object.

The issue is because of the UI macro 'kb_search_results_v3' customized on the instance.

https://SERVICENOW.service-now.com/sys_ui_macro.do?sysparm_record_list=nameSTARTSWITHkb_search_results_v3%5EORDERBYname&sysparm_record_rows=1&sysparm_record_row=1&sysparm_record_target=sys_ui_macro&sys_id=0bf9b043ff3031003f07ffffffffff3b&sysparm_nostack=true

 

Resolution

UI Macro: kb_search_results_v3
When reverted the customization to out of the box and tested the functionality, it is working as expected.


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