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Unable to capture the list element changes when captured directly from the sys_ui_list" in an update set - Support and Troubleshooting
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KB0791684

Unable to capture the list element changes when captured directly from the sys_ui_list" in an update set


3873 Views Last updated : Apr 8, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Unable to capture the list element changes when captured directly from the sys_ui_list" in an update set

Steps to reproduce:

  1. Login to the instance <abc>
  2. Navigate to System Update Sets -> Local Update Sets
  3. Create a new update set <xyz> and "Submit and Make Current"
  4. Navigate to sys_ui_list.LIST
  5. Open any record ( Ex: Table Incident )
  6. Under the List Elements, create a new list element and submit 

Release

All

Cause

Update sets track customizations under these conditions:

  • Where the table has an update_synch dictionary attribute.
  • Where there is a special handler to track changes to multiple tables.
  • Where the administrator has not excluded a field from updates.

The table "sys_ui_element_list" for type "collection" does not have "update_synch" attribute configured. Hence, any changes on "sys_ui_element_list" table will not get captured in update set. 

This is expected behavior and out of the box functionality. 

 

Please note : 
Do not add the update_synch attribute to a dictionary record. When improperly used, this attribute can cause major performance issues or cause the instance to become unavailable. Adding this attribute is not supported. 

Please find the documentation below. 
https://docs.servicenow.com/csh?topicname=customizations-tracked-update-sets.html&version=latest 

Resolution

Any changes on sys_ui_element_list table will not get captured in update set. This is expected behavior.

Related Links

Business Rule : Update Synch Check

This business rule will not allow to add 'update_synch' attribute to a dictionary entry. If we try to add, it will show the error "Cannot add an update_synch attribute to a dictionary entry"


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