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[SAMP/Adobe Integration] SAM - Import User Subscriptions - scheduled job fails for Adobe subscriptions with "Unhandled Exception" error - Support and Troubleshooting
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  • [SAMP/Adobe Integration] SAM - Import User Subscriptions - scheduled job fails for Adobe subscriptions with "Unhandled Exception" error
KB0791527

[SAMP/Adobe Integration] SAM - Import User Subscriptions - scheduled job fails for Adobe subscriptions with "Unhandled Exception" error


3550 Views Last updated : Apr 8, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

  •  The "SAM - Import User Subscriptions" schedule job fails for the Adobe subscriptions with an error,
 "SAM:SAM - Import User Subscriptions: Adobe - Unhandled exception: TypeError: Method and Endpoint must be defined: no thrown error"

Release

  • Instance with Software Asset Management Professional plugin installed.

Cause

  •  The error "SAM:SAM - Import User Subscriptions: Adobe - Unhandled exception: TypeError: Method and Endpoint must be defined: no thrown error" points to an issue with the configuration of the Adobe integration profile.

Resolution

  • Login to the affected instance.
  • Navigate >> SaaS License >> Administration >> All Integration Profiles and open the Adobe Subscription profile and click "Validate Adobe Credential" UI Action. However, it fails with the message "Connection Failed".

  • Meantime if you navigate >> Multi-Provider SSO >> x509 Certificate and choose associated Adobe certificate and click "Validate Stores/Certificates" UI Action it succeeds.

  • Probable reason would be because the integration profile must be misconfigured.
  • In order to fix this issue, validate the configuration of the Adobe integration profile by following the "Set up Adobe Cloud License Management" documentation.
Note: The password used in creating the private/public key should be the same as the certificate record password in ServiceNow instance.


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